Skip to main content

Symptom

Der Agent nutzt die Hybrid Search, liefert aber keine Ergebnisse oder antwortet mit „Ich konnte keine relevanten Informationen finden”, obwohl passende Dokumente im Space vorhanden sind.

Mögliche Ursachen

  • Die Dokumente wurden noch nicht vollständig geparst (Verarbeitung läuft noch).
  • Der gewählte Parser hat den Inhalt nicht korrekt extrahiert (z.B. bei gescannten PDFs ohne OCR).
  • Die Frage passt nicht zum Inhalt der Chunks – die Information ist vorhanden, aber anders formuliert.
  • Dem Agenten ist das Hybrid-Search-Werkzeug nicht zugewiesen.

Lösung

1

Verarbeitungsstatus prüfen

Öffnen Sie Daten → Dokumente und prüfen Sie, ob alle relevanten Dokumente den Status „Verarbeitet” haben. Frisch hochgeladene Dateien benötigen einige Sekunden bis Minuten.
2

Parser-Einstellungen prüfen

Unter Space-Einstellungen → Parser kontrollieren Sie, ob für den Dateityp ein geeigneter Parser ausgewählt ist. Für gescannte Dokumente empfiehlt sich mistral_ocr.
3

Werkzeug-Zuweisung prüfen

Stellen Sie in der Agent-Konfiguration sicher, dass das Werkzeug Hybrid Search dem Agenten zugewiesen ist.
4

Frage umformulieren

Versuchen Sie, Ihre Frage konkreter oder mit anderen Begriffen zu stellen. Die Suche arbeitet sowohl mit Schlüsselwörtern als auch semantisch.
Wenn ein Dokument schlecht geparst wurde, können Sie den Parser wechseln und das Dokument erneut hochladen. Die docling-Parser erzielen bei Dokumenten mit Tabellen und komplexem Layout oft bessere Ergebnisse.